INTRO(4) BSD Programmer's Manual (i386) INTRO(4)
intro - introduction to special files and hardware support
The manual pages in section 4 describe the special files, related driver functions, and networking support available in the system. In this part of the manual, the SYNOPSIS section of each configurable device gives a sample specification for use in constructing a system description for the config(8) program. The DIAGNOSTICS section lists messages which may ap- pear on the console and/or in the system error log /var/log/messages due to errors in device operation; see syslogd(8) for more information. This section contains both devices which may be configured into the sys- tem and network related information. The networking support is introduced in netintro(4).
This section describes the hardware supported on the i386 (PC-clone) platform. Software support for these devices comes in two forms. A hardware device may be supported with a character or block device driver, or it may be used within the networking subsystem and have a network interface driver. Block and character devices are accessed through files in the file system of a special type; see mknod(8). Network interfaces are indirectly accessed through the interprocess communication facilities provided by the system; see socket(2). A hardware device is identified to the system at configuration time and the appropriate device or network interface driver is then compiled into the system. When the resultant system is booted, the autoconfiguration facilities in the system probe for the device and, if found, enable the software support for it. If a device does not respond at autoconfigura- tion time it is not accessible at any time afterwards. To enable a device which did not autoconfigure, the system will have to be rebooted. The autoconfiguration system is described in autoconf(4). A list of the supported devices is given below.
The devices listed below are supported in this incarnation of the system. Pseudo-devices are not listed. Devices are indicated by their functional interface. Not all supported devices are listed. aac(4) Adaptec "FSA" family (Adaptec AAC, Dell PERC, HP NetRaid) RAID controllers. addcom(4) Addonics FlexPort serial boards. adv(4) AdvanSys PCI narrow SCSI Host Adapters. adw(4) AdvanSys PCI wide SCSI Host Adapters. aha(4) Adaptec 154x ISA SCSI adapter boards. ahb(4) Adaptec 1742 EISA SCSI adapter boards. ahc(4) Adaptec 2xxx and 3xxx series PCI/VLB/EISA SCSI adapter boards. aic(4) Adaptec AIC-6260, Adaptec AIC-6360, Adaptec 152x, and SoundBlaster SCSI boards. amdpm(4) AMD768 Power Management. ami(4) American Megatrends Inc. MegaRAID Controllers. an(4) Aironet Communications 4500/4800 IEEE 802.11DS wire- less network adapter. apm(4) Advanced Power Management. aria(4) Sierra Semiconductor Aria 16 sound cards. ast(4) Multiplexing serial communications card first made by AST. aue(4) ADMtek AN986-based USB Ethernet adapters. auich(4) Intel 82801AA/AB/BA and 440MX PCI audio. auvia(4) VIA VT82C686A and VT8233 integrated AC'97 audio dev- ice. awi(4) BayStack 650 PCMCIA wireless network adapter. az(4) Aztech/PackardBell FM Radio card. bce(4) Broadcom BCM4401 Ethernet. bge(4) Broadcom BCM570x (Tigon3) Gigabit Ethernet boards. bha(4) Buslogic BT-445, BT-74x, and BT-9xx SCSI boards. bktr(4) Brooktree video capture. boca(4) BOCA serial cards. cac(4) Compaq Smart ARRAY RAID controllers. clcs(4) Cirrus Logic CS4280 audio. clct(4) Cirrus Logic CS4281 audio. cmpci(4) C-Media CMI8x38 audio. cnw(4) Xircom CreditCard Netwave wireless network adapter. cue(4) CATC USB-EL1201A based USB Ethernet adapters. cy(4) Cyclades Cyclom-4Y, -8Y, and -16Y asynchronous serial adapters. cz(4) Cyclades Cyclades-Z asynchronous serial adapters. dc(4) DEC tulip clone ethernet cards (Macronix, Lite-On, Davicom, ADMtek). de(4) DEC tulip-based ethernet cards. dpt(4) DPT SmartCache/SmartRAID III and IV SCSI controllers. eap(4) Ensoniq AudioPCI (ES137x) audio. ec(4) 3Com EtherLink II Ethernet (3C503). ef(4) 3Com Fast EtherLink ISA Ethernet (3C515). eg(4) 3Com EtherLink Plus Ethernet (3C505). el(4) 3Com EtherLink Ethernet (3C501). elansc(4) AMD Elan SC520 System Controller. em(4) Intel i82542, i82543, and i82544 Pro/1000 Gigabit Ethernet. emu(4) Creative Labs SBLive! and PCI 512 audio. ep(4) 3Com EtherLink III Ethernet (3C5x9, 3C59x). esa(4) ESS Alegro 1 and Maestro 3 audio. eso(4) ESS Technology Solo-1 PCI AudioDrive (ES1938/ES1946) audio. ess(4) ESS Technology AudioDrive (ESS 1788, 1888, 1887 and 888) audio. ex(4) Intel EtherExpress PRO/10 ethernet cards. fdc(4) Floppy disk controllers. fea(4) DEC DEFEA PCI FDDI controller. fms(4) Forte Media FM801 audio. fpa(4) DEC DEFPA PCI FDDI controller. fxp(4) Intel EtherExpress PRO/100 Ethernet. gdt(4) ICP-Vortex GDT RAID controllers. geodesc(4) Geode SC1100 System Controller. gtp(4) Gemtek PCI FM radio adapter. gus(4) Gravis UltraSound and UltraSound/MAX audio. hifn(4) Hifn 7751 crypto accelerator. hsq(4) Hostess multiplexing serial communications boards. ie(4) StarLAN 10, EN100, StarLan Fiber, and 3Com 3c507 Eth- ernet. iha(4) Initio INIC-940 and INIC-950 based SCSI interfaces. iop(4) I2O adapter. ises(4) Securealink PCC-ISES hardware crypto accelerator. isp(4) QLogic PCI SCSI controllers. it(4) ITE IT8705F, IT8712F and SiS SiS950 hardware moni- tors. iy(4) Ether-Express PRO/10. joy(4) Joystick. kue(4) Kawasaki LSI KL5KUSB101B-based USB Ethernet. lc(4) DEC EtherWORKS III Ethernet. le(4) BICC Isolan, Novell NE2100, and Digital DEPCA Ether- net. lge(4) Level 1 LXT1001 NetCellerator PCI gigabit ethernet. lmc(4) Lan Media Corporation SS1/DS1/HSSI/DS3 PCI WAN adapters. lms(4) Logitech-style bus mouse. lofn(4) Hifn 6500 crypto accelerator. lpt(4) Parallel port. maestro(4) ESS Maestro 1, 2 and 2E audio. mcd(4) Mitsumi CD-ROM drives. mms(4) Microsoft-style bus mouse. mpt(4) LSI Fusion-MPT SCSI and FibreChannel host adapter driver nsclpcsio(4) National Semiconductor PC87366 LPC Super I/O. ncr(4) NCR PCI SCSI adapter boards. ne(4) Novell NE1000 and 2000 Ethernet interface. neo(4) NeoMagic 256AV/ZX audio. nge(4) National Semiconductor PCI Gigabit Ethernet. nofn(4) Hifn 7814/7851/7854 HIPP1 crypto processor. npx(4) Numeric Processing Extension coprocessor and emula- tor. opl(4) Yamaha OPL2 and OPL3 FM synthesizer. pas(4) ProAudio spectrum audio. pccom(4) NS8250-, NS16450-, NS16550-, ST16550-, TI16750- and XR16850-based asynchronous serial communications. pcdisplay(4) PC display adapter driver for MDA or CGA compatible adapters. pckbc(4) Traditional PC (ISA) keyboard. pctr(4) CPU performance counter registers. pms(4) PS/2 auxiliary port mouse, for generic mice. pmsi(4) PS/2 auxiliary port mouse, for wheel mice. pss(4) Personal Sound System audio. puc(4) PCI ``universal'' communications card driver. ray(4) Raytheon Raylink/WebGear Aviator wireless network adapter. rl(4) Realtek 8129/8139 Ethernet. rt(4) AIMS Lab Radiotrack FM radio adapter. rtfps(4) Another multiplexing serial communications card. safe(4) Safenet SafeXcel 1141/1741 crypto accelerator. sb(4) Sound Blaster card. sea(4) Seagate/Future Domain SCSI cards. sf(4) Adaptec AIC-6915 Starfire PCI Fast Ethernet. sf2r(4) SoundForte RadioLink SF16-FMR2 FM radio adapter. sf4r(4) SoundForte RadioLink SF64-PCR FM radio adapter. sfr(4) SoundForte RadioLink SF16-FMR FM radio adapter. siop(4) LSI/Symbios Logic/NCR 53c8xx SCSI adapter boards. sis(4) SiS 900, Sis 7016 and NS DP83815 Fast Ethernet. sk(4) SysKonnect 984x Gigabit Ethernet (9841/9842/9843/9844). sm(4) SMC91C9x Ethernet. speaker(4) Console speaker. ste(4) Sundance Technologies ST201 Fast Ethernet. stge(4) Sundance/Tamarack TC9021 Gigabit Ethernet. sv(4) S3 SonicVibes cards. tcic(4) Databook PCMCIA controllers. ti(4) Alteon Tigon I & II Gigabit ethernet (3Com 3C985, Netgear GA620, etc). tl(4) Texas Instruments ThunderLAN ethernet. tr(4) IBM TROPIC Token-Ring adapters. trm(4) TRM-S1040 based PCI SCSI Host Adapters. twe(4) 3ware Escalade RAID controller. tx(4) SMC 9432 10/100 Mbps Ethernet cards. txp(4) 3Com 3XP Typhoon/Sidewinder (3CR990) Ethernet. uaudio(4) USB audio devices. ubsec(4) Broadcom Bluesteelnet uBsec 5501, 5601, 5805, and 5820. udsbr(4) D-Link DSB-R100 USB radio adapter. uftdi(4) FTDI FT8U100AX-based USB serial adapters. uha(4) Ultrastor ISA and EISA SCSI adapter cards. ukbd(4) USB keyboard. ulpt(4) USB printers. umass(4) USB mass storage. umct(4) MCT USB-RS232 serial adapter. umidi(4) USB MIDI devices. umodem(4) USB modems. ums(4) USB mouse. upl(4) Prolific PL2301/PL2302-based host-to-host USB connec- tors. uplcom(4) I/O Data USB-RSAQ2 USB serial adapters. urio(4) Diamond Multimedia Rio MP3 device interface. url(4) Realtek RTL8150L USB ethernet adapter. uscanner(4) USB scanners. usscanner(4) SCSI-over-USB scanners. uvisor(4) Handspring Visor device interface. uyap(4) YAP phone firmware interface. vga(4) PC display adapter driver for VGA compatible adapters. vr(4) VIA Rhine Ethernet. wb(4) Winbond W89C840F fast ethernet. wdc(4) Standard ISA Western Digital type hard drive con- trollers. MFM, RLL, ESDI, and IDE. wds(4) WD-7000 SCSI host adapters. wdt(4) Industrial Computer Source PCI-WDT50x watchdog timer cards. we(4) Western Digital/SMC WD 80x3, SMC Elite Ultra and SMC EtherEZ Ethernet cards. wi(4) WaveLAN/IEEE and PRISM-II 802.11DS wireless network adapters. wss(4) Windows Sound System audio. wt(4) Wangtek and compatible tape drives. QIC-02 and QIC- 36. xe(4) Xircom PCMCIA Ethernet. xl(4) 3Com EtherLink XL and Fast EtherLink XL (3c9xx). yds(4) Yamaha DS-XG audio. ym(4) Yamaha OPL3-SAx audio.
The i386 intro first appeared in NetBSD 1.0. MirOS BSD #10-current May 16, 1999 3
Generated on 2014-02-10 02:47:05 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.