NPX(4) BSD Programmer's Manual (i386) NPX(4)
npx - Numeric Processing Extension coprocessor and emulator
option GPL_MATH_EMULATE npx0 at isa? port "IO_NPX0" irq 13
The npx driver enables the use of the system's Numeric Processing Exten- sion coprocessor, if one is present. Numeric processing extensions are present in systems with 486DX CPUs and in systems with 387 or 487SX coprocessors. The npx driver is required for proper system functioning regardless of whether or not a NPX is present. If there is no NPX present in the system option GPL_MATH_EMULATE must be defined in the kernel configuration file. It will provide support for the instructions normally executed by the NPX. If there is no NPX in the sys- tem and the kernel is not built with math emulation, the system will not boot.
The emulator is much slower than the NPX coprocessor. This will result in poor floating-point math performance if the emulator must be used.
There are lots of them, especially on cheap motherboards. In particular, some motherboards do not have the interrupt lines from the NPX to the CPU wired properly. If this is the case, the emulator must be used if con- sistent system operation is desired. Emulation of the transcendental functions instructions is incorrect. Emu- lation of other instructions is suspect. MirOS BSD #10-current August 6, 1993 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.