RTFPS(4) BSD Programmer's Manual RTFPS(4)
rtfps - multiplexing serial communications interface
rtfps0 at isa? port 0x1230 irq 10 com* at rtfps? slave ? or pccom* at rtfps? slave ?
The rtfps driver provides support for IBM RT PC boards that multiplex to- gether up to four RS-232C (CCITT V.28) or RS-422A communications inter- faces. Each rtfps device is the master device for up to four com devices. The kernel configuration specifies these com devices as slave devices of the rtfps device, as shown in SYNOPSIS. The port specification for the rtfps device is used to compute the base addresses for the com subdevices.
com(4), intro(4), isa(4)
The rtfps driver was written by Charles Hannum, based on the ast driver.
The rtfps driver is unlikely to work on non-PCI machines. The ISA bus only asserts 10 I/O address lines, and this is not enough. Even on PCI machines, some address conflicts have been observed. On one machine, the second port always conflicted with something (though it's not clear what) and caused strange results. Disabling the second port in the kernel config allowed the other three ports to function correctly. MirOS BSD #10-current August 7, 1994 1
Generated on 2013-04-27 00:20:00 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.