SHELLS(5) BSD Reference Manual SHELLS(5)
shells - shell database
The shells file contains a list of valid shells available on the system. A shell is a command line interpreter that reads user input and executes commands. For each shell a single line should be present, consisting of the shell's path, relative to root. A hash mark ('#') indicates the beginning of a comment; subsequent char- acters up to the end of the line are not interpreted by the routines which search the file. Blank lines are also ignored. The chpass(1) program will not let regular users change their default shell to one not listed in the shells file. The ftpd(8) daemon denies ac- cess to users who are not using one of the listed shells.
chpass(1), login(1), getusershell(3), nologin(8)
The shells file format appeared in 4.3BSD-Tahoe. MirOS BSD #10-current June 5, 1993 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.