INSTALL.SPARC(7) BSD Reference Manual INSTALL.SPARC(7)
install.sparc - stub installation instructions for the sparc architecture
This manual page describes how to install the MirOS operating system on a sparc (sun4c, sun4m) machine.
The MirOS homepage (see below) contains a comprehensive list of possibil- ities to get bootable installation media. In many cases, you will down- load MirOS from the internet via HTTP or BitTorrent. On some conferences and fairs, you can also get CDs directly from the developers. You can also mail them to have a CD sent to you if you don't have broadband. For more information, refer to the install.i386(7) manual page for now. You can either boot from a pretty minimal floppy image floppy10.fs, from a CD-ROM image (either the full CD or the minimal cdrom10.iso image), or netboot a bsd.rd ELF format gzip'd kernel using boot, formerly called boot.net, or netboot a directly bootable bsd.rd.net a.out format kernel.
This section is a stub. For now, refer to the OpenBSD documentation at http://pub.allbsd.org/OpenBSD/3.5/sparc/INSTALL.sparc for details or ask in IRC. You can usually replace the server# ln -s boot.MACHINE.OpenBSD.$KARCH 8273900B.$KARCH line with server$ sudo ln -s bsd.rd.net 8273900B.$KARCH to make use of our netbootable kernels. Note that "8273900B" is the hexa- decimal, big-endian representation of the IPv4 address.
The sparc architecture does not use MBR partitioning, so that you can skip reading about the fdisk utility in the i386 instructions. On the contrary, rather than storing a native BSD disklabel in sector #1 inside the MirOS partition, a Sun disklabel is stored in sector #0 of the medi- um. It is important that the 'a' slice begin at sector #0 as well.
Please see the install.i386(7) manual page for a detailled walkthrough. This manual page currently is only a stub.
boot_sparc(8), disklabel(8), diskless(8) The MirOS homepage: http://mirbsd.de/
Support for the sparc architecture first appeared in MirOS #7ter. It re- appeared in MirOS #10, although the floppy image came back only with MirOS #11, promoted to a fully supported architecture. MirOS BSD #10-current October 30, 2008 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.