BIO(4) BSD Programmer's Manual BIO(4)
bio - ioctl tunnel pseudo-device
pseudo-device bio [count] [count]
The bio driver provides userland applications ioctl access to devices otherwise not found as /dev nodes. The /dev/bio device node operates by delegating ioctl(2) calls to a requested device driver. Only drivers which have registered with the bio device can be accessed via this inter- face. If count is given in the specification, and is greater than 0, a maximum of one bio device is created. The following ioctl(2) calls apply to the bio device: BIOCLOCATE Locate a named device and give back a cookie to the applica- tion for subsequent ioctl calls. The cookie is used to tunnel further ioctls to the right device.
/dev/bio ioctl tunnel device
The bio driver appeared in OpenBSD 3.2. MirOS BSD #10-current June 8, 2002 1
Generated on 2013-04-27 00:20:00 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.