CGSIX(4) BSD Programmer's Manual (SPARC) CGSIX(4)
cgsix - accelerated 8-bit color frame buffer
cgsix* at sbus? slot ? offset ? (sun4c and sun4m) cgsix0 at obio0 addr 0xfb000000 level 4 (sun4/300 P4) cgsix0 at obio0 addr 0x0b000000 level 4 (sun4/100 P4) wsdisplay* at cgsix?
The cgsix is a color frame buffer with graphics acceleration, available as an SBus card for sun4c and sun4m, or as a P4 bus card for sun4 works- tations. The cgsix driver interfaces the frame buffer with the wscons(4) console framework. It does not provide direct device driver entry points but makes its functions available via the internal wsdisplay(4) interface. Different cgsix frame buffer models exist, with various memory sizes and capabilities. The cgsix driver supports the four flavours: GX GX+ Turbo GX (or TGX) Turbo GX+ (or TGX+)
If the cgsix frame buffer is used as the console display, a different resolution than the default 1152x900 can be selected by changing the OpenPROM environment. To change the default resolution, type the follow- ing: ok setenv output-device screen:r1280x1024x76 to change to a 76Hz 1280x1024 resolution. If the cgsix frame buffer is a secondary display, or a serial console is used, the display resolution can not be changed without using an nvramrc OpenPROM script. Refer to the Sun Frame Buffer FAQ for details. The cgsix frame buffer accepts the following resolutions: screen:r1022x1000x76 1022x1000, with a refresh rate of 76Hz. Only avail- able on the SPARCstation IPX on-board frame buffer. screen:r1024x768x60 Super VGA 1024x768, with a refresh rate of 60Hz. Only available on TGX and TGX+. screen:r1024x768x70 Super VGA 1024x768, with a refresh rate of 70Hz. Only available on TGX and TGX+. screen:r1024x768x76 Super VGA 1024x768, with a refresh rate of 76Hz. Only available on TGX and TGX+. screen:r1024x768x77 Super VGA 1024x768, with a refresh rate of 77Hz. Only available on the SPARCstation LX on-board frame buffer. screen:r1024x800x74 1024x800, with a refresh rate of 74Hz. Only avail- able on TGX and TGX+. screen:r1024x800x85 1024x800, with a refresh rate of 85Hz. Only avail- able on the SPARCstation IPX on-board frame buffer, as well as on GX+, TGX and TGX+. screen:r1152x900x66 Standard 1152x900, with a refresh rate of 66Hz. This is the default setting on the dual-slot GX models (501-1481 and 501-1645). screen:r1152x900x76 Standard 1152x900, with a refresh rate of 76Hz. This is the default setting on the on-board or single-slot GX models, as well on TGX. screen:r1280x1024x67 High res 1280x1024, with a refresh rate of 67Hz. Only available on the SPARCstation LX with the VSIMM installed, as well as on GX+ and TGX+. This is the default on GX+. screen:r1280x1024x76 High res 1280x1024, with a refresh rate of 76Hz. Only available on TGX+, where this is the default setting. screen:r1600x1280x76 High res 1600x1280, with a refresh rate of 76Hz. Only available on the SPARCstation LX with the VSIMM installed, as well as on GX+ and TGX+. The 1600x1280 resolution is not officially supported by Sun on the GX+.
agten(4), bwtwo(4), cgeight(4), cgfour(4), cgfourteen(4), cgthree(4), cgtwelve(4), cgtwo(4), intro(4), mgx(4), pninek(4), pnozz(4), rfx(4), sbus(4), tcx(4), tvtwo(4), vigra(4), wscons(4), wsdisplay(4), zx(4) Sun Frame Buffer FAQ, http://www.sunhelp.org/faq/FrameBuffer.html.
Several firmware revisions of the cgsix, in particular those found in the SPARCstation 5, have a bug that occurs when the screen control sequences for inserting blank lines (e.g., the control sequences produced by the 'al' and 'AL' capabilities found in the termcap(5) database) are used near the bottom end of the screen. This bug is most likely to be encoun- tered during the use of a full-screen editor such as vi(1) on the workstation's console. To work around this bug, the TERM environment variable should be set to 'sun-ss5', which is the same as the 'sun' entry except without the 'al' and 'AL' capabilities. MirOS BSD #10-current January 5, 2003 1
Generated on 2012-09-10 15:20:00 by $MirOS: src/scripts/roff2htm,v 1.73 2012/07/01 16:04:30 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2011 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.