CRYPTO(4) BSD Programmer's Manual CRYPTO(4)
crypto - hardware crypto access driver
pseudo-device crypto [count] [count]
The crypto driver provides userland applications access to hardware cryp- to support via the kernel. The /dev/crypto device node primarily operates in an ioctl(2) based model, permitting a variety of applications to query device capabilities, submit transactions, and get results. If count is given in the specification, and is greater than 0, a maximum of one crypto device is created. The following ioctl(2) calls apply only to the crypto devices: CIOCGSESSION Set up a new crypto session for a new type of operation. CIOCFSESSION Free a previously established session. CIOCCRYPT Perform a crypto operation against a previously set up ses- sion.
Depending on hardware being present, the following symmetric and asym- metric cryptographic features are potentially available from /dev/crypto: CRYPTO_DES_CBC CRYPTO_3DES_CBC CRYPTO_BLF_CBC CRYPTO_CAST_CBC CRYPTO_SKIPJACK_CBC CRYPTO_MD5_HMAC CRYPTO_SHA1_HMAC CRYPTO_RIPEMD160_HMAC CRYPTO_MD5_KPDK CRYPTO_SHA1_KPDK CRYPTO_AES_CBC CRYPTO_ARC4 CRYPTO_MD5 CRYPTO_SHA1 CRK_MOD_EXP CRK_MOD_EXP_CRT CRK_DSA_SIGN CRK_DSA_VERIFY CRK_DH_COMPUTE_KEY
/dev/crypto crypto access device
hifn(4), ises(4), lofn(4), noct(4), nofn(4), safe(4), ubsec(4), crypto(9)
The crypto driver appeared in OpenBSD 3.0. MirOS BSD #10-current May 13, 2001 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.