GEM(4) BSD Programmer's Manual GEM(4)
gem - GEM gigabit ethernet interface
gem* at pci? dev ? function ? bmtphy* at mii? phy ? brgphy* at mii? phy ? eephy* at mii? phy ? lxtphy* at mii? phy ?
The gem interface provides access to the 10Mb/s, 100Mb/s and 1Gb/s Ether- net networks. The gem is found on the Sun GEM and ERI 10/100 boards, as well as the Apple internal GMAC ethernet. Each of the host's network addresses is specified at boot time with an SIOCSIFADDR ioctl(2). The gem interface employs the address resolution protocol described in arp(4) to dynamically map between Internet and Eth- ernet addresses on the local network. When a gem interface is brought up, by default, it will attempt to auto- negotiate the link speed and duplex. The speeds are tried in descending order; first in full duplex mode, then half duplex. The gem driver supports several media types, which are selected via the ifconfig(8) command. The supported media types are: media autoselect Attempt to autoselect the media type (default) media 1000baseT mediaopt full-duplex Use 1000baseT on copper, full duplex media 1000baseT [mediaopt half-duplex] Use 1000baseT on copper, half duplex media 1000baseSX mediaopt full-duplex Use 1000baseSX on fiber, full duplex media 1000baseSX [mediaopt half-duplex] Use 1000baseSX on fiber, half duplex media 100baseTX mediaopt full-duplex Use 100baseTX, full duplex media 100baseTX [mediaopt half-duplex] Use 100baseTX, half duplex media 10baseT mediaopt full-duplex Use 10baseT, full duplex media 10baseT [mediaopt half-duplex] Use 10baseT, half duplex
arp(4), bmtphy(4), brgphy(4), eephy(4), ifmedia(4), inet(4), intro(4), lxtphy(4), netintro(4), hostname.if(5), ifconfig(8)
OpenBSD support for gem first appeared in OpenBSD 3.0. MirOS BSD #10-current October 5, 2001 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.