PMS(4) BSD Programmer's Manual PMS(4)
pms, pmsi - PS/2 auxiliary port mouse driver
pms* at pckbc? pms* at gsckbc? (hppa) pmsi* at pckbc? wsmouse* at pms? wsmouse* at pmsi?
The pms drivers provide an interface to PS/2 auxiliary port mice within the wscons(4) framework. Parent device in terms of the autoconfiguration framework can be either gsckbc(4), the PS/2 input port controller found on hppa machines, or pckbc(4), the standard PC keyboard controller found on most other machines. "pms" is a generic driver which supports 2 coor- dinate axes and 3 buttons. The "pmsi" variant provides specific support for wheel mice of the "IntelliMouse" breed; wheel movements are mapped to a third (z-) axis. Mouse related data are accessed by wsmouse(4) devices.
gsckbc(4), intro(4), lms(4), mms(4), pckbc(4), ums(4), wsmouse(4) MirOS BSD #10-current March 12, 1997 1
Generated on 2013-04-27 00:20:00 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.