SD(4) BSD Programmer's Manual SD(4)
sd - SCSI disk driver
sd* at scsibus? target ? lun ? #sd0 at scsibus0 target 3 lun 0 (fixed-configuration example)
The sd driver provides support for a SCSI disk. It allows the disk to be divided up into a set of pseudo devices called partitions. In general the interfaces are similar to those described by wd(4). SCSI devices have a fairly high level interface to the system and talk to it via a SCSI host adapter (e.g., ahc(4)). A SCSI adapter must also be separately configured into the system before a SCSI disk can be config- ured. When the SCSI adapter is probed during boot, the SCSI bus is scanned for devices. Any devices found which answer as 'Direct' type devices will be attached to the sd driver.
On many systems disklabel(8) is used to partition the drive into filesys- tems. On some systems the OpenBSD portion of the disk resides within a native partition, and another program is used to create the OpenBSD por- tion. For example, the i386 port uses fdisk(8) to partition the disk into a BIOS level partition. This allows sharing the disk with other operating systems.
The following ioctl(2) calls apply to SCSI disks as well as to other disks. They are defined in the header file <sys/disklabel.h>. DIOCGDINFO Read, from the kernel, the in-core copy of the disklabel for the drive. This may be a fictitious disklabel if the drive has never been initialized, in which case it will contain in- formation read from the SCSI inquiry commands. DIOCSDINFO Give the driver a new disklabel to use. The driver will not write the new disklabel to the disk. DIOCWLABEL Enable or disable the driver's software write protect of the disklabel on the disk. DIOCWDINFO Give the driver a new disklabel to use. The driver will write the new disklabel to the disk. DIOCLOCK Lock the media cartridge into the device, or unlock a car- tridge previously locked. Used to prevent user and software eject while the media is in use. DIOCEJECT Eject the media cartridge from a removable device. In addition, the scsi(4) general ioctl() commands may be used with the sd driver, but only against the 'c' (whole disk) partition.
If a removable device is attached to the sd driver, then the act of changing the media will invalidate the disklabel and information held within the kernel. To avoid corruption, all access to the device will be discarded until there are no more open file descriptors referencing the device. During this period, all new open attempts will be rejected. When no more open file descriptors reference the device, the first next open will load a new set of parameters (including disklabel) for the drive.
/dev/sdup block mode SCSI disk unit u, partition p /dev/rsdup raw mode SCSI disk unit u, partition p
intro(4), scsi(4), wd(4), disklabel(5), disklabel(8), fdisk(8)
The sd driver was originally written for Mach 2.5, and was ported to FreeBSD by Julian Elischer. It was later ported to OpenBSD. MirOS BSD #10-current January 18, 1996 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.