NETSTART(8) BSD System Manager's Manual NETSTART(8)
netstart - command scripts for network startup
/etc/netstart [interface ...]
netstart is the command script that is invoked by rc(8) during an au- tomatic reboot and after single user mode is exited; it performs network initialization. The netstart script can also be used to start newly-created bridges or interfaces, or reset existing interfaces to their default state. The behaviour of this script is (or can be) controlled to some extent by variables defined in /etc/rc.conf, which specifies which daemons and ser- vices are to be run. During the system boot, netstart is executed. netstart will perform the following operations: • Set the machine's name. • Configure the loopback interface. • Configure all the physical interfaces. • Initialize the routing table and set up the default routes. • Configure all the gif(4) and gre(4) interfaces. • Configure all the bridges. After the system is completely initialized, it is possible to start a newly-created interface or bridge(4), or reset an existing interface to its default state, by invoking sh /etc/netstart foo0 where foo0 is the interface or bridge name.
Routing to the 22.214.171.124/4 net is set up using values from /etc/rc.conf according to these rules: • If the multicast settings are as follows: multicast_host=NO multicast_router=NO then multicast routing will not be enabled. • If the multicast settings are as follows: multicast_host=NO multicast_router=YES then multicast routing will be enabled, but no multicast route will be set up. It is expected that a routing daemon, such as mrouted(8), will be started as well. • If the multicast settings are as follows: multicast_host=YES multicast_router=NO or: multicast_host=foo0 # interface name multicast_router=NO then multicast routing will be enabled, using the default interface, or the interface name specified by multicast_host. • Other cases are configuration errors and will cause multicast routing not to be enabled.
bridge(4), gif(4), gre(4), bridgename.if(5), defaultdomain(5), hostname.if(5), mygate(5), myname(5), dhcp(8), mrouted(8), rc(8), rc.conf(8)
The netstart command appeared in 4.0BSD. MirOS BSD #10-current February 20, 2002 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.