SYSLOGC(8) BSD System Manager's Manual SYSLOGC(8)
syslogc - collect messages from syslog memory buffer
syslogc [-Ccoq] [-s reporting_socket] logname syslogc [-Cc] logname syslogc -q
syslogc collects messages from the syslogd(8) memory buffer specified by the logname argument. For syslogc to work, syslogd(8) must be configured with one or more memory buffer logs (see syslog.conf(5) for details) and have a reporting socket location specified on the commandline (using the -s option to syslogd(8)). By default, syslogc will query the specified log and return it to stan- dard output. The options are as follows: -C Request that the log buffer be cleared without reading it. -c Request that the log buffer be cleared once it has been read. -o Check whether the specified log has overflowed. If the log has overflowed, then a message will be printed to stdout(4) and the exit status will be set to 1. -q Request a list of available logs. -s reporting_socket Specify alternate reporting socket location (the default is /var/run/syslogd.sock).
syslog(3), syslog.conf(5), syslogd(8)
The syslogc command first appeared in OpenBSD 3.5. MirOS BSD #10-current November 2, 2003 1
Generated on 2013-04-27 00:20:00 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.