WSCONSCTL(8) BSD System Manager's Manual WSCONSCTL(8)
wsconsctl - get or set wscons state
wsconsctl [-d /dev/ttyC0] [-k /dev/wskdb0] [-m /dev/wsmouse0] [-n] -a wsconsctl [-d /dev/ttyC0] [-k /dev/wskdb0] [-m /dev/wsmouse0] [-n] name ... wsconsctl [-d /dev/ttyC0] [-k /dev/wskdb0] [-m /dev/wsmouse0] [-n] name=value ... wsconsctl [-d /dev/ttyC0] [-k /dev/wskdb0] [-m /dev/wsmouse0] [-n] name+=value ...
The wsconsctl command displays or sets various wscons system driver vari- ables. If a list of variables is present on the command line, wsconsctl prints the current value of those variables for the specified device. Similarily, if a list of top-level entries is present, wsconsctl prints the current values of their children. The options are as follows: -a Print all device variables and their current values. -d ctldev Set the control device for display to ctldev. -k ctldev Set the control device for keyboard to ctldev. -m ctldev Set the control device for mouse to ctldev. -n Suppress printing of the variable name in the output. name=value Attempt to set the specified variable name to value. The value can be specified as either an absolute, by using the '=' symbol, or as a relative value, by using the '+=' symbol. See the EXAMPLES section for more details. The wsconsctl utility can be used to view and modify aspects of the key- board, display, and mouse using the standard, machine-independent works- tation console device driver wscons(4). The keyboard type can be modified, the keyboard bell's pitch, period, and duration can be modified, the typematic value can be changed, and the keyboard encoding can be modified to switch keys, should the user find a keyboard's default layout difficult to use. There are also definitions relating to video control and cursor control, which are not applicable to all display types, and to text emulation and graphics (mapped) modes. Use the kbd(8) utility to determine which keyboard encodings are avail- able for your country.
/dev/ttyC0 display control device /dev/wskbd0 keyboard control device /dev/wsmouse0 mouse control device /etc/wsconsctl.conf a list of parameters that get set at system startup time from rc(8) /usr/include/dev/wscons/wsconsio.h keyboard/mouse/display definitions
Set a UK keyboard encoding: # wsconsctl keyboard.encoding=uk Modify the current keyboard encoding so that, when the Caps Lock key is pressed, the same encoding sequence as Left Control is sent. For a full list of keysyms, and keycodes, please refer to the /usr/include/dev/wscons/wsksymdef.h file. # wsconsctl keyboard.map+="keysym Caps_Lock = Control_L" Assign the Right Alt key to be the group modifier (layout is changed while the key is pressed): # wsconsctl keyboard.map+="keycode 184=Mode_switch" Assign the Right Control key to be the lock for the group modifier. The effect of Mode_Lock and Mode_switch is not mutually exclusive, to be con- sistent with Caps Lock and Shift behaviour. # wsconsctl keyboard.map+="keycode 157=Mode_Lock" Set a US keyboard encoding, with the Caps Lock and Left Control keys swapped. The .swapctrlcaps encoding does not work for all national key- board encodings. For most purposes, the ability to set the value returned by the Caps Lock key is enough - see the previous example for details. # wsconsctl keyboard.encoding=us.swapctrlcaps Set the bell pitch to be 1200: # wsconsctl keyboard.bell.pitch=1200 Add 200 to the current pitch of the bell: # wsconsctl keyboard.bell.pitch+=200
pckbd(4), wscons(4), wsconsctl.conf(5), kbd(8), wsconscfg(8), wsfontload(8)
The wsconsctl command first appeared in NetBSD 1.4 and OpenBSD 2.8. The ability to print subtrees, similar to sysctl(8), and the -d, -k, and -m options first appeared in MirOS #11. MirOS BSD #10-current December 4, 2008 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.